KIRIYAMA Kazuhiko
2021-05-26 01:08:16 UTC
Hi, all
I'm trying to boot Levono Chroebook S330 [1]. I've made FreeBSD USB image in
accordance with [2] as follows :
# gpart destroy -F /dev/da0
da0 destroyed
# gpart create -s GPT da0
da0 created
# gpart add -b 1m -s 15m -t \!fe3a2a5d-4f32-41a7-b725-accc3285a309 da0
da0p1 added
# gpart add -b 17m -s 15m -t \!fe3a2a5d-4f32-41a7-b725-accc3285a309 da0
da0p2 added
# gpart add -t freebsd-ufs da0
da0p3 added
# dd if=nv_uboot-snow-simplefb.kpart of=/dev/da0p1 bs=1m
0+1 records in
0+1 records out
696320 bytes transferred in 0.297577 secs (2339966 bytes/sec)
# newfs_msdos /dev/da0p2
/dev/da0p2: 30656 sectors in 3832 FAT12 clusters (4096 bytes/cluster)
BytesPerSec=512 SecPerClust=8 ResSectors=1 FATs=2 RootDirEnts=512 Sectors=30720 Media=0xf0 FATsecs=12 SecPerTrack=63 Heads=255 HiddenSecs=0
# mdconfig -a -t vnode -f FreeBSD-14.0-CURRENT-arm64-aarch64-20210429-daa5350d0e0c-258262-memstick.img
md0
# gpart show md0
=> 3 1646232 md0 GPT (804M)
3 66584 1 efi (33M)
66587 1579648 2 freebsd-ufs (771M)
# mount /dev/md0p2 /mnt
# mount_msdosfs /dev/da0p2 /mnt1
# cp /mnt/boot/kernel/kernel.bin /mnt1
# umount /mnt1
# newfs -U /dev/da0p3
/dev/da0p3: 1880.0MB (3850200 sectors) block size 32768, fragment size 4096
using 4 cylinder groups of 470.00MB, 15040 blks, 60160 inodes.
with soft updates
super-block backups (for fsck_ffs -b #) at:
192, 962752, 1925312, 2887872
# mount /dev/da0p3 /mnt1
# tar -cf - -C /mnt . | tar -xf - -C /mnt1
# umount /mnt
# umount /mnt1
# mdconfig -d -u md0
# gpart show da0
=> 40 7864240 da0 GPT (3.8G)
40 2008 - free - (1.0M)
2048 30720 1 chromeos-kernel (15M)
32768 2048 - free - (1.0M)
34816 30720 2 chromeos-kernel (15M)
65536 7798744 3 freebsd-ufs (3.7G)
#
and then mark the FreeBSD USB device bootable :
# cgpt add -P 12 -T 5 -S 1 -i 1 /dev/sda
# reboot
confirmed partition 1 attributes changed to :
# cgpt show /dev/sda
...
Attr: priority=12 tries=5 successful=1
...
# shutdown -P now
and insert USB device and power the machine on and press CTRL+U at the "OS
verification is OFF" screen, but screen blackout and nothing has happened
;-(
How the machine go forth to boot with u-boot ?
Best regards
[1] https://www.lenovo.com/jp/ja/kakaku/notebooks/lenovo/lenovo-n-series/Lenovo-Chromebook-S330/p/88LGCS31095?vc_lpp=MSY5ZWQ2NGNhNzc2JjYwYTIxZTdhJmRhJjYwZjEzODc5JllLSWVlUUFISUNja05OUUJ3S2hwQ2NDb2FTZTZodyY0CVlLSWVlUUFISUNja05OUUJ3S2hwQ2NDb2FTZTZodwkwODc4ODc5MDgwMDIwOTYwNjAyMTA1MTcwNzQyNDkJCQk&cid=jp%3Aaffiliate%3Ag2ospo
[2] https://wiki.freebsd.org/action/show/arm/Chromebook?action=show&redirect=FreeBSD%2Farm%2FChromebook
---
Kazuhiko Kiriyama <***@TreuFC.org>
I'm trying to boot Levono Chroebook S330 [1]. I've made FreeBSD USB image in
accordance with [2] as follows :
# gpart destroy -F /dev/da0
da0 destroyed
# gpart create -s GPT da0
da0 created
# gpart add -b 1m -s 15m -t \!fe3a2a5d-4f32-41a7-b725-accc3285a309 da0
da0p1 added
# gpart add -b 17m -s 15m -t \!fe3a2a5d-4f32-41a7-b725-accc3285a309 da0
da0p2 added
# gpart add -t freebsd-ufs da0
da0p3 added
# dd if=nv_uboot-snow-simplefb.kpart of=/dev/da0p1 bs=1m
0+1 records in
0+1 records out
696320 bytes transferred in 0.297577 secs (2339966 bytes/sec)
# newfs_msdos /dev/da0p2
/dev/da0p2: 30656 sectors in 3832 FAT12 clusters (4096 bytes/cluster)
BytesPerSec=512 SecPerClust=8 ResSectors=1 FATs=2 RootDirEnts=512 Sectors=30720 Media=0xf0 FATsecs=12 SecPerTrack=63 Heads=255 HiddenSecs=0
# mdconfig -a -t vnode -f FreeBSD-14.0-CURRENT-arm64-aarch64-20210429-daa5350d0e0c-258262-memstick.img
md0
# gpart show md0
=> 3 1646232 md0 GPT (804M)
3 66584 1 efi (33M)
66587 1579648 2 freebsd-ufs (771M)
# mount /dev/md0p2 /mnt
# mount_msdosfs /dev/da0p2 /mnt1
# cp /mnt/boot/kernel/kernel.bin /mnt1
# umount /mnt1
# newfs -U /dev/da0p3
/dev/da0p3: 1880.0MB (3850200 sectors) block size 32768, fragment size 4096
using 4 cylinder groups of 470.00MB, 15040 blks, 60160 inodes.
with soft updates
super-block backups (for fsck_ffs -b #) at:
192, 962752, 1925312, 2887872
# mount /dev/da0p3 /mnt1
# tar -cf - -C /mnt . | tar -xf - -C /mnt1
# umount /mnt
# umount /mnt1
# mdconfig -d -u md0
# gpart show da0
=> 40 7864240 da0 GPT (3.8G)
40 2008 - free - (1.0M)
2048 30720 1 chromeos-kernel (15M)
32768 2048 - free - (1.0M)
34816 30720 2 chromeos-kernel (15M)
65536 7798744 3 freebsd-ufs (3.7G)
#
and then mark the FreeBSD USB device bootable :
# cgpt add -P 12 -T 5 -S 1 -i 1 /dev/sda
# reboot
confirmed partition 1 attributes changed to :
# cgpt show /dev/sda
...
Attr: priority=12 tries=5 successful=1
...
# shutdown -P now
and insert USB device and power the machine on and press CTRL+U at the "OS
verification is OFF" screen, but screen blackout and nothing has happened
;-(
How the machine go forth to boot with u-boot ?
Best regards
[1] https://www.lenovo.com/jp/ja/kakaku/notebooks/lenovo/lenovo-n-series/Lenovo-Chromebook-S330/p/88LGCS31095?vc_lpp=MSY5ZWQ2NGNhNzc2JjYwYTIxZTdhJmRhJjYwZjEzODc5JllLSWVlUUFISUNja05OUUJ3S2hwQ2NDb2FTZTZodyY0CVlLSWVlUUFISUNja05OUUJ3S2hwQ2NDb2FTZTZodwkwODc4ODc5MDgwMDIwOTYwNjAyMTA1MTcwNzQyNDkJCQk&cid=jp%3Aaffiliate%3Ag2ospo
[2] https://wiki.freebsd.org/action/show/arm/Chromebook?action=show&redirect=FreeBSD%2Farm%2FChromebook
---
Kazuhiko Kiriyama <***@TreuFC.org>